Whack your Neighbor

5,082 495 share

WARNING: this game is quite bloody! Don't play it if you are below 16 or of sensitive nature.

Have fun with Whack your Neighbor! Or play Whack the Creeps, a great new game in the series!

More Games In This Series

Whack Your Ex  -  Whack Your Computer  -  Whack Your Boss: Superhero Style  -  Whack Your Boss 2: Fantasy Edition  -  Whack Your Boss  -  Whack the Thief  -  Whack The Terrorist  -  Whack the Creeps  -  Whack the Cheater  -  Whack the Burglars  -  Whack My Phone
» Whack your Neighbor
Whack your Neighbor Video Walkthrough
Whack your Neighbor

Whack your Neighbor Walkthrough

Whack your Neighbor is an engaging action game that you can play here on CrazyGames directly in your browser. Whack your Neighbor is powered by Flash technology to work smoothly in modern browsers. Whack your Neighbor has been played 484,374 times and has been rated 9.1 / 10 with 5,572 votes. Did you like playing this game? Then take a look at our other action games such as Whack Your Ex and Whack the Burglars.

Home | About | Games for your Site | Game Developers | Jobs | Scholarship | Terms & Conditions | Privacy | Contact

© Copyright 2013 - 2018 - Find us on Google Plus is an initiative of Maxflow BVBA, Lei 33/402, 3000 Leuven, Belgium.(VAT: BE 0550.758.377)

Click 'Allow' to play Whack your Neighbor! Click 'Always allow' to play Whack your Neighbor!

Some of the games on need Flash. You need to allow it above. You only need to do this once.

Flash is a multimedia platform used for browser games, videos, and other rich internet applications. Every game on CrazyGames is thoroughly tested and checked for viruses and other threats, following our strict content guidelines. This is why you can be absolutely sure that playing Flash games on CrazyGames is completely safe. If you have any questions or concerns, feel free to contact us.

If the Allow button is not appearing, make sure to wait until loading the page is finished. If it's still not working, reach out and let us know which browser and which version of it you are using.